Unable to register Unity

Hey guys, I was searching through the questions here and haven’t really found an answer to the problem I am experiencing.

I recently decided that Unity would be a great engine to use to to do some simple game dev, so last night I downloaded and installed the most recent unity version from the website and since then I have had a real struggle even getting it to start. Unity version is what ever is the latest and I am trying to run it on a MacBook Pro with the latest version of Yosemite. Here is the problem I am having -

Upon starting Unity after installing, I get a little window that pops up with nothing but an “500 - Internal Server Error” message. Sometimes it will come up with the option to select my license, but most times it’s this error.

I tried doing a manual activation, but even going to the website I was constantly getting this error message, and would have to refresh the page, so I am assuming that there is currently problems with the license server? I guess that’s kind of question number 1.

Question number 2 would be that I was eventually able to get through the manual activation part online, and would download a text file, Unity_v4.X.ulf.txt, that the web page tells me is the license file. However, when I go to try and load it in Unity I have one of two problems happen. -

I either get a box that pops up telling me that I don’t have a license with the option to load or save one. This is where I saved the file that I loaded into the manual activation web page to create my license. However, from here if I go to try and load the license that I was given by the server, it won’t let me select the file that I downloaded.

I have also tried going to the Unity>Manage License menu selection, but Manage License is grayed out.

I was really looking forward to learning Unity, but I have never seen an application be so much trouble simply to get registered. Am I missing something here that is causing issues? Thanks in advance!

It seems some users are getting in trouble with the 500 internal server error in the last few days, may be Unity team is doing something on their web server. I suggest you to contact their customer support on the forum or contact form, because of course the community cannot do anything about it.