Unable to start adb server. Make sure the android sdk is installed and properly configured.,Unable to start adb server. Please make sure the Android sdk is installed and properly configured in the Editor.

Every time I try to build my android game it shows this error. I’ve added the sdk and jdk using add modules in the unity hub. I’ve tried updating unity and reinstalling the update too. When I try to run adb devices it says something about version 41 not matching version 40 (paraphrasing). It crashes at first but when I run it again it shows the same version message but, with a device number this time.,I’m unable to build my app. It is an android game for cardboard VR. I’ve updated the software and added the jdk and sdk. I do not know why this is happening. Could you guys help me?

You may have a different version of adb install on your system (from another piece of software).

In my case, I found that the Oculus Developer Hub program came with its own version of ADB, and that copying the following files from my Unity platform-tools folder into the Oculus Developer Hub folder resolved the issue. After copying the files, I ran stopped any adb.exe processes running (using Task Manager), and then restarted Unity.


  • adb.exe
  • AdbWinApi.dll
  • AdbWinUsbApi.dll

Unity folder:

Oculus Developer Hub folder:
C:/Program Files/Oculus Developer Hub/resources/bin

problem fixed here : Unity 2020 Android Support: Setup, SDK & NDK & JDK & Gradle - YouTube

For anyone else, in my case there was an emulator running and I wanted to build and run my game on my Android device. So I got the error. Closed the emulator and it fixed!

I had installed Xr plugin and Oculus plugin in the same project and this is why I couldnt make the build. Uninstall XR plugin works for me, I did it because I didnt use any script of this package.