Uncaught ReferenceError: unityFramework is not defined at HTMLScriptElement.script.onload (WebGL)

Any suggestions?

Is WebGL is non functional in 2020.1 alpha?

1 Like

Try to disable compression.

8 Likes

Disabling compression worked for me: 2020.1.0.a.2166

5 Likes

Hello hippocoder ! Thanks for posting! I've logged the bug here - https://issuetracker.unity3d.com/issues/urp-webgl-build-fails-when-urp-is-used-in-project

4 Likes

Hi @hippocoder Are you successfully building with URP?
Im facing difficulties for Webgl URP https://discussions.unity.com/t/773719

Thanks!

The error occurs in both OSX and Windows standalone builds too using otherwise the same repro steps, reproducible / non-reproducible with the same 2020.1 alpha versions as the above logged bug @The_Unity_Cat

2 Likes

Hi, with 2020.1 disable compression, in player "Publishing Settings" , Compresion Format and it works.
The tracked bug is locked to vote up bug.

Thanks @OneManArmy3D && @TheCritters

6 Likes

should be fixed for 20.1a24

1 Like

I fought with the same issue for days. Sometimes it worked, sometimes not. It stopped loading after 90%. After disabling the compression, the size increased from 60Mb to 80Mb but now it works. Thanks a lot.
(I use Version 2020.1.0b2.3333)

1 Like

If you are still having this issue please do file a new bug report with a repro project and some extra info like what browsers you see this in, the browser log and any other extra info you can think of. Thanks!

I've ran into the same issue in 2020.1b5 using webGL, trying to play it in opera

edit: gzip crashes when i try to build, brotli crashes when i try to play.. webGL with compression has been broken for so long it's getting ridiculous when you consider that there's a 1-line workaround that could have been implemented

For us, it won’t load even an empty project in 2020.1b5. (gzip or brotli)
Turnining compression off solves it, but builds are too big.

@Schubkraft when do you think this will be solved?

As well as VideoPlayer from URL. Saw that it is on the known issues list.

We solved it partially by turning on gzip on the server.
Build is still in uncompressed format, but what is sent from the server is now much smaller.

even with gzip enabled, Im still seeing unityFramework not defined.. Im on apache.. I looked at https://docs.unity3d.com/Manual/webgl-deploying.html but this hasnt helped fix the unityframework issue.

PS I also noticed that the toggle full screen button doesnt show when on my website like it does when run from unity

Could be related to this issue: https://issuetracker.unity3d.com/product/unity/issues/guid/1229961/

We’d have to look into your case though to be sure, so a bug report would be best.

@LeonhardP already did - but was hoping someone had some ideas - the full screen button issue went away with the new beta. However, I tried IE, edge, firefox and chrome and none seemed to like the compressed deployment

Could you please share the report ID here?

Hi, 1241196

1 Like

Thanks, we'll have a look.

Just reporting this still happens in 2020.1.0b7 (gzip compression fails with error).