Undefined symbols for architecture i386: with 200+ apple mach-o linker (Id) errors

I have just purchased Unity iOS 3.4.2f2 and am running it on an Apple Macbook running 10.6.8 Snow Leopard.
I am using XCode 4.2 on the same computer.

I have tried several simple example Unity projects and have run the default build for iOS and when I try to build them in XCode for the iPhone 5.0 Simulator, I get the following 201 apple mach-o linker (Id) errors:

ld: warning: ignoring file /Users/Shared/Unity/TestProj/iOSbuild/Libraries/libiPhone-lib.a, missing required architecture i386 in file

Undefined symbols for architecture i386:

“UnityUse32bitDisplayBuffer()”, referenced from:
CreateWindowSurface(EAGLView*, unsigned int, unsigned int, unsigned int, bool, EAGLSurfaceDesc*) in AppController.o
OpenEAGL_UnityCallback(UIWindow**, int*, int*, int*) in AppController.o

“UnityGetTargetResolution()”, referenced from:
CreateSurface(EAGLView*, EAGLSurfaceDesc*) in AppController.o

“UnitySetInputScaleFactor(float)”, referenced from:
CreateSurface(EAGLView*, EAGLSurfaceDesc*) in AppController.o

…201 apple mach-o linker (Id) errors.

I get the same build errors with all Unity iOS projects I have tried.

Over the past couple of weeks, I have attempted all of the fixes suggested in the unityAnswers forum and have had no success whatsoever.

As a new user, I am probably missing something obvious for you experienced guys. It is stopping me dead in the water from progressing onto any useful app development.

Please point me in the right direction, so that I can move forward with my work.

I figured it out!

Being new to Unity iOS and XCode, I didn’t realise you need to set the Unity Player Settings SDK Version to iOS Simulator to have XCode build and run in the iPhone simulator. Hence the “Undefined symbols for architecture i386:” errors. Makes sense now.

Runs in the simulator and on the physical iPhone now.

Very disappointed that over 200 viewers of this question and nobody even made a suggestion to point me in the right direction on such a novice error.

It worked! Thanks

How did you archive to iOS device? I am stuck in this part.

Set the Unity build settings to iOS device and run the build.
Then in Xcode, plug your iOS device into your computer and select the device name at the top of the screen and press the run arrow button to build and run the app on your physical iOS device.

Hope this answers your question.