UNET Windows Connection Problem

I’m running a server using UNET LLAPI. When I run it on a mac, I am able to connect from external machines ( as well as the same machine) with no problem. However if I run the server on windows, I am no longer able to connect from external machines (though loopback on the same machine still works fine). The connection simply doesn’t register. If I debug, the breakpoint for all NetworkEventTypes (except “Nothing”) are never hit. I checked wireshark, and the packets are indeed hitting the right port. I even tried disabling the firewall, to no avail. Any idea what could be happening? Is this a windows setting? A UNET issue?

Ok. I found the answer. The firewall wasn’t disabled. I had disabled the firewall for private networks and not for public networks. Obviously I would like to use this with the firewall still up, To do that I looked into the firewall rules. For some reason, There were two rules named “Unity Editor” that were blocking traffic for unity. I am still unclear as to how these rules popped into existence, but disabling them worked (Edit: I also needed to add a rule allowing traffic from the remote IP Address). If someone wants to shed more light on this, I’d be grateful.