Unitron and multipart identifiers

Does anyone know how to make Unitron for the Mac respect period-delimited identifiers? It seems that by default, double clicking on the "foo" in foo.bar.baz will select "foo.bar.baz" instead of just foo. Likewise, when doing option+right arrow to move around code, it treats foo.bar.baz as a single word, instead of jumping to bar and then baz.

I suspect this might be a generic Mac setting, not something specific to Unitron, but I haven't been able to figure out how to change it.

That sounds strange. I don't know how to change it, but on my machine, "foo.bar.baz" is treated as three words, both for double-clicking, and for option+arrow combos. It works the same way in other places in the system, like on the web page.

If it's the wrong way for you all over the system, then it's probably not a Unitron setting, but a system wide setting. Maybe it's related to the international settings (Number formats, etc)?

Problem solved! I had to go to System Preferences->Language & Text->Text and change the "Word Break" drop-down from Standard to "English (United States, Computer)".

Thanks to Jonas for his help.