Unity 2.02 Game is no more working on Mountain Lion

We created our game with unity 2.02 and it worked perfectly with MacOSX Lion but not under Mountain Lion. It simply crashes after opening. We think it has to do with changed graphic drivers or changed security stuff.
We tried to convert our old source version with unity 4.0 but we got too many errors as expected. So there is not an easy way to get a new version out of it. Any other experience here or ideas what we can do…
thanks in advance

There are reports that Unity 3 works with Mountain Lion (although some developers do have problems):


Personally, I converted a Unity 2 Project to Unity 3.5 and the conversion was successful (on my 2nd attempt). Nevertheless, I needed to make some adjustments on the successfully converted v.3.5 converted project (but issues were easy to spot and correct). If I remember well,the shaders implementation changed from Unity v.2 to v.3, and that’s what causes the problems.

There maybe problems converting the -converted- Unity 3 project to 4 (so, maybe you don’t want to covert all the way to Unity 4 yet):

Here is where you can download previous versions of Unity:

In conclusion, it seems that your best bet for getting your project to work with Mountain Lion, is to convert you Unity v2 project to v.3 (v. 3.5.6 to be more precise) and after getting this to work, and if you feel adventurous enough, try to convert the Unity 3.5.6 project to v.4. But even if the latter doesn’t work, the 3.5.6 project should work with Mountain Lion, or in any case, that should be where your efforts should be concentrated.