Unity 2017.2 how to disable Vuforia?

I went through the “Getting Started with Vuforia in Unity 2017.2” instructions. But now I want a scene with no AR camera. My scene has nothing other than a Main Camera, and I’ve gone into player settings and turned off Vuforia support. But when I click play in the editor, my camera is automatically turned into a Vuforia ARCamera. Is there a way to turn this off without having to start a new project?

For 2017.3 I was able to do that by using below code:
using Vuforia;

void Start(){
VuforiaBehaviour.Instance.enabled = false; // Where ever you want the Vuforia not to work just do this.
}

I just found out. For future I am putting this here so even if I forget I will come here and get my answer ready :slight_smile:

Have you tried setting XRSettings.enabled to false in that scene?

Yeah that seems to be the answer. For some reason in my original project that didn’t work, but when I started up a new project, I was able to toggle Vuforia support on and off using XRSettings.enabled.

Thanks!

[SOLVED] You can just enable/disable the Vuforia camera using the VuforiaBehavior component.

void StartCamera () {
    vuforiaBehavior.enabled = true;
}

void StopCamera () {
    vuforiaBehavior.enabled = false;
}