Unity 2017.3.1f1 crash after Developer Tools on Mac request access

I am currently developing an app that uses firebase 4.5.0 API with user authentication and unity store subscription for iOS and Android. We’ve also installed JWT library with VS for security issues. After some implementation, this window started appearing frequently with the message “Developer Tools Access needs to take control of another process for debugging to continue.” :

123199-screen-shot-2018-08-22-at-153732.png

The thing is:

1.If I cancel Unity Crashes and every time I open Unity again and it needs to compile a change in script, this window appear again.

2.If I continue, every time I need to compile Unity crashes.

When we open Unity again, it is compiled and we can test, but it is painfull to crash unity every single time we change something in code.

It is still happening time to time, but not as frequent as it was. I cannot say that the workaround below fixed the issue, but it does ease the pain a lot!


What I did:

  1. Update Catalina to latest
  2. Uninstall all apps you use with Unity - including Unity Hub
  3. Reinstall all apps back again (if possible, use the latest stable Unity release - just in case)

I think this is kind of a workaround to set required permissions properly after updating Catalina


I think the issue is related to new Catalina update requiring more permissions for safety and did not consider already installed apps in a proper way - having trouble with even Adobe suite even after reinstalling them. Catalina is garbage for me right now.


Currently I am using:

  • MacOS Catalina 10.15.3
  • Unity 2019.3.0f6

This is happening frequently in Catalina (10.15.3) with Unity 2019.3of6. Worse, the hangup is so bad that force quit doesn’t do anything. The app icon goes away but the app itself stays open. Would love to figure out how to avoid this. There’s no obvious set of behaviors triggering it.

  • OS: MacOS Catalina 10.15.3 CPU: 2.5
  • GHz Quad Core Intel i7
  • Graphics : AMD + Radeon R9 M370X 2 GB + Intel Iris Pro 1536 MB

UPDATE:
Guys, I’m not gonna copy and paste here the whole thing since it’s very long, but here’s the link to the stackoverflow with my question and my answer. Maybe it will help you somehow.

https://stackoverflow.com/questions/62152562/enabling-developer-tools-access-crashes-unity-and-activity-monitor/62408952#62408952

------- Old version of this message:

Hey guys, I’m facing the same issue.

I’m facing the Developer Tools problem since yesterday. I use:

  • Unity (several different versions, e.g. 2018.4.23),
  • Jetbrains Rider (updated today to 2020.1.3, yesterday 2020.1.2)
  • macOS Catalina 10.15.5

I was refactoring some stuff and Developer Tools asked me for the access: Developer Tools Access needs to take control of another process for debugging to continue. Enter your password to allow this…

Since then, two things are happening.

If Developer Tools Access is enabled (also tried doing this through sudo /usr/sbin/DevToolsSecurity --enable command) nearly every time when I’m changing something in code, Unity stops working (loading wheel present) and I can’t turn its application off. I tried using Activity Monitor, it doesn’t show any activities. I can only see the loading wheel.

I even tried killing the Unity process through kill unitypid, it “kills” the process since it’s not present on the processes list, but I still can see it on my desktop, being just as down as before.

Checking Unity logs, I can see it stops on:

Begin MonoManager ReloadAssembly

custom-attrs.c:1250: (null) 
   assembly:/Applications/Unity/Hub/Editor/2018.4.17f1/Unity.app/Contents/Managed/UnityEngine/UnityEngine.CoreModule.dll type:UnityException member:(null) signature:<none>

Stacktrace:
Native stacktrace:
    0   libmonobdwgc-2.0.dylib              0x00000001460b4976 mono_handle_native_crash + 242

If Developer Tools Access is disabled, the application asks me a few times to enable it. After pressing Cancel a few times, Unity crashes and turns off and gives me the ability to send log error to Apple with the exception:

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY
Application Specific Information:
abort() called

Don’t really know what to do. I tried updating Rider, Catalina, installing a new Unity version.

Your help would be much appreciated!

I too, had this happen many times. It’s up to the point where I save my work every 5 minutes or so, because it might just happen at any time. Very, very frustrating to use Unity at the moment.
Reinstalled both the hub and Unity, but no change so far.

  • Model: 27-inch, 2017
  • MacOS Catalina 10.15.3
  • CPU 3,4GHZ Quad-Core Intel i5
  • Mem: 40 GB 2400 Mhz DDR4
  • Graphics: Radeon Pro 570 4GB
  • Unity Version: 2019.3.3f1

I’m having the same issue, for me it is 100% of the time as soon as I click Continue. I just updated to Catalina when this was happening, never had an issue before. I’m using 2018.4.18f1 which I installed fresh, however, I did not reinstall hub, so I will try that next. If that doesn’t work, I’ll try to update to 2019 unity and see if that helps. For what it’s work, if I don’t give it access (just leave the window up), I can still run my game, but I guess I can’t debug this way? I’ll update if anything changes, but wanted to post it here with my info so Unity can take a look.

MacOS Catalina 10.15.3
MacBook Pro (Retina, Mid 2012)
2.3 GHz Quad-Core Intel Core i7
16 GB 1600 MHz DDR3
NVIDIA GeForce GT 650M 1 GB
Unity: 2018.4.18f1

Open the Terminal (Mac) and type:

sudo /usr/sbin/DevToolsSecurity --enable

Done! This solved the issue for me.

I’m also having this issue. Since I updated to Mac’s OS to Catalina I can’t use Unity without it hanging and the DeveloperTools window popping up every 5-10 minutes. It keeps crashing my Unity. I’ve uninstalled and reinstalled Unity on my Mac, but it still didn’t work.

Has this issue been fixed or being addressed in the latest version of unity?

  • MacOS Catalina 10.15.3
  • Unity Version: 2019.3.2f1
  • MacBook Pro (Retina, 15-inch, Mid 2015), 2.5 GHz Quad-Core Intel Core i7, Intel Iris Pro 1536 MB

I also have the same problem, and I tried both solutions (Reinstall, enable dev tools security) here but to no avail. I just thought of something my HDD is formatted as APFS could this be the problem, does everyone here has the same format or not??
I was thinking of reinstalling the whole system again, and changing the HDD formatting but wanted to make sure that everyone having the problem have the same format.