Unity 2017, no offline mode for launcher?

I lost the internet connection on two occasions recently and I was really surprised to find out that the 2017 Launcher can’t load my recent projects, thus preventing me from working on them.

What happens is, the launcher fills the blue bar until the end and then nothing. The list stays blank.

I’m not sure if this is a bug or 2017 requires us to be always online, but my Unity is activated and I do find this as a problem.
Even when clicking on the recent project from the context menu in the taskbar, Unity will load launcher.
There is no way to open any project as far as I know, without going through the launcher.

Is there a way to force Launcher to launch in offline mode or?

Disable network and working offline appear

@Srki94
i tried to turn off my connection,
and then turn it on again,
close the app,
open it again,
and its working fine again,
hope its work :slight_smile:

Bit of a shitty bug and shitty solution.


I have the same problem too

,I have the same problem too

Is there ANY solution to this problem?..anyone from the company that can help?..I have been reading about this problem in few places - lot of plp having this problem (including me)…any help please?

Same here. I travel a lot and this is a major problem. None of the suggested solutions work for me.

Very bad story, we have unity installed on production server with no internet. Purchased pro license, but can do nothing…

I had the same issue with 2017.2.1f1 2017.3.0f3 2017.3.1p1
Restarting editor with WiFi turned off did not work.

Only rebooting and then retrying the launcher 2 more times worked.

I have problem with 2018.2.18f and found a solution:
Go to the project folder you want to open in unity and open your scene (“.unity” file)
It’s open whole project in offline mode.