Unity 2018.2.6 Unable to open editor, open project or new project even after uninstall and reinstall of Hub and Unity

This morning I attempted to open up a project using Unity 2018.2.6f1 on my computer, no issues yesterday or for months. Upon trying to open the project from Hub, no editor would open and no errors were produced.
I tried opening the project directly with the Unity 2018.2.6f1 executable and I was told that the project was locked. I deleted the TEMP lock file and still ran into the same issue each time. No other versions of unity were running or open in my task manager. I attempted to uninstall and reinstall through hub with the same problem.
I then uninstalled all versions of unity and hub and reinstalled hub and 2018.2.6f1 and I still have the same problem.
I am unable to open the editor and see a new project or old project. For new projects, the folder structure is created, but the editor never opens. Unity also does not appear in the task manager anywhere, just unity hub.
Any suggestions on a fix? This is a rather large project with months of work behind it.

Update -
Still not working, installed Unity 2019.2.20f1 and am able to have the editor open in that version. However, not with 2018.2.6f1 (which I have to use to support a specific type of hardware).

I purged all of appdata local and roaming and 2018.2.6f1 still won’t open the editor on existing projects or newly created ones.

FYI - This is was solved by reinstalling Windows 10 and leaving existing files in place.