Unity 2018.3.7f1 (Editor) not starting after loading a project

When i run unity a popup comes up on my screen and i see everything loading, when it is done unity doesn’t start up and it just runs as a background process. I tried reinstalling, switching versions, turning off my antivirus etc. Does anyone know why this is happening? I’ve been trying to fix it for hours.

Now it’s not responding?

Edit 2:

Same thing is happening to me. When i open a project it stops responding and opens unity hub back up. The only way i found that I can load in is by going to the project folder and opening a scene from the asset folder.,Dude the same thing is happening to me. Unity Hub also pops back up and I can’t do anything. The only way I am able to load in is by going to the project folder and load up a scene within the game.

Are you using the Unity Hub launcher to install / uninstall?

Definitely late, but oh well.

Unity requires windows update KB2533623, which isn’t available to download on Windows since January 2020. I’d get the KB3063858 update, or, if possible, the KB4457144 update, and it should work then. If you can’t get both, you need to download KB3063858 at minimum. If you already have them, and it still doesn’t work, try to make a DEP Exception.