unity 2018.3 Upgrade - Terrain Broken - Inspector tab is a duplicate?

So after upgrading to 2018.3 My game no longer works.

At first my player character was floating about 60 meters higher than they should be.
It took me a while to figure out it had something to do with the collider.
For some reason the terrain collider is reporting something wrong.

So then I look at the terrain and I see this:
4175266--369028--upload_2019-2-2_8-39-32.png

I have tried everything I could think of but the message never goes away.

Do I need to upgrade this terrain using some tool or something?
What am I missing?

Update:
I see that it doesn't like multiple inspector windows.
But still have a problem with the terrain collider.

Update 2:
So I tried creating a new terrain and that works but using my existing terrain does not.
Any way to import the old terrain into a new one?

Closing all open Inspector tabs then opening a new one fixed this for me.

3 Likes

Guys, i Fixed It (Just ReOpen You're Project)

1 Like

Yep not fixed in 2019.1.2f1. Nothing so far works for me to fix it. Resetting layouts, new scenes, restarting, none of that works.

4 Likes

Yep not fixed- Having same problem in 2019.1.2f1 as of today. Did all above (Snacktime ) as well - Nothing works. Ouch

1 Like

Same problem. I have 2019.1.2f1 also. This is a documented issue in the Issue Tracker, but it says it's fixed (supposedly fixed in 2019.2 and back-ported into 2019.1.2) and the issue is marked closed. But it is certainly NOT fixed, and I don't know how to get a known Issue like this re-opened (or if anyone can). Kinda sloppy to mark something as big a deal as this fixed when it's really not. Closing windows, resetting defaults, restarting Unity, re-importing projects, clearing the Library, deleting the terrains, making new terrains - nothing I have tried fixes it.

Wow this sucks - brand new shiny Unity full release and the terrain edit is broke *sigh

Erelos you documented my day instead of getting anything done. :) did everything you did- no go.

Are you guys using Vegetation Studio Pro? I’ve had the same problem and tracked it down to be related, could be some side effect with the latest Unity version and one of the scripts. I’m not sure, so I asked the dev to investigate. Other assets might have similar problems. If you’re not using VS Pro, are you using other scripts with your terrain?

Main project where I first noticed this has Veg Studio Pro and a ton of other stuff (very large project). So after several minutes of expletives sigh, to test it I made a clean new Unity project 2019.1.2f1 and only created a terrain and did some stuff to it. You can edit the terrain one time. If you change focus, or go back to it, or restart that project the bug shows up. I can't think of a time I used 2 inspector windows - so it actually can't just be that. It just "thinks" there is another inspector window. Oh, the Issue ID is #1117658* if anyone wants to reference it.

If I could find that inspector window I'd stomp on it good. This Unity 2019.1.2f1 Pro is NO PRO :(

This was my case.

The issue is definitely not resolved, but it is directly related to having either Vegetation Studio or Vegetation Studio Pro in your project. I opened a clean project in 2019.1.2f1, created a terrain, could paint on it, etc. I then imported Vegetation Studio and had the issue. Same story with Vegetation Studio Pro.

Given that Vegetation Studio / Vegetation Studio Pro have to be present for the issue to happen I don't know if the fix will have to come from Unity Technologies or Awesome Technologies. That being said someone should definitely alert Awesome Technologies of this problem.


@LennartJohansen summon. :)

[quote]
@LennartJohansen summon. :)
[/quote]

Hi. I had a look at this. Unity added some internal test that did not validate the inspector as "itself" when extended with reflection.

I will make a workaround and update. For now delete the ExtendedTerrainEditor.cs file and things should work.

Lennart

8 Likes

Thanks for looking at it. Will give this a try. YAY for good support :smile:

And it works !! TYVM LennartJohanse

Having this error too, but without Vegetation Studio (or pro) imported. In Unity 2019.1.3f1. :(

1 Like

I have the same issue without vegetation studio.

What I found that works for me in build 2018.3.11f1 is to select a different layout in the top right corner of the Editor and then to go back to my preferred layout.
a) Save your current layout as you prefer it.
b) Select one of the default layouts example 2 by 3 or 4 split.
c) Select your saved layout again and the Terrain paint tool is available again.

In the future we just have to repeat step b and c, which is just 2 clicks but still a pain that we have to use solutions like this and a fix would be appreciated in 2018 builds.

2 Likes

I ran into this error, too, with 2018.4.3f1.

EDIT:
So, I checked the mentioned script ExtendedTerrainEditor.cs that we should delete. I’m using VS Pro 1.2.0 and it looks like the fix Lennart applied was just to exclude the whole class file like this:

#if UNITY_2019_1_OR_NEWER
#else
...original code
#endif

Well, that’s one way to do it. So I modified it to also make it work with my current version 2018.4.3f1 instead of just deleting the file

#if UNITY_2018_4_OR_NEWER
#else
...original code
#endif

@LennartJohansen Please update this for when you release an update. Thanks!

1 Like

the problem after deleting the ExtendedTerrainEditor.cs, the vegitation studio doesn’t update vegetation when painting texture layers, you have to check/uncheck the “Load Terrain Details” tab in vegetation system to refresh it

also i am not able to see the terrain brush stamp preview, so i cant tell where i am painting. i am using the 2018.4.5f1

I simply changed from normal to debug mode and then back again. This was just for the duplicate inspector window issue which is quite annoying. Fixed.