Unity 2018.3 VR build for Daydream View is sideways

Hey everyone,

The title pretty much says it all.

I’m trying to render out the sample HelloVR Scene from the GoogleVR unity package.

I started a new Lightweight RP VR project, then imported the GoogleVR package. Then I brought up the HelloVR Scene from the package assets and removed/closed the Sample scene that came up when I started the project.

I’m using my Asus Zenfone AR and Android 7.0 SDK (as that’s the version on my phone).

When I preview it on my computer, it’s oriented correctly. The wall and objects are vertical as they should be. But when I hit Build and Run, my phone shows it rotated 90 degrees clockwise. I checked the cameras and setting, but I couldn’t figure out why it would do that. I also checked the developer settings on my phone but couldn’t find anything there either. No idea how to get a screenshot of that funny business to show you guys.

Any advice/suggests? Anyone else run into this on any other device?

Prashant

had the same issue, reinstalled gvr services on phone then it had gone away.

Hi thebricktop,

Thanks for the response. It seems all of my vr apps are doing the same. Even those native to the phone. I tried your suggestion. I was only able to uninstall and update Google vr services. Open to any additional advice. Thanks again.