Unity 2018 is not adding bundle identifier in Xcode Build Settings

On building ios xcode project through unity, value for product bundle identifier is not set in the build settings tab in xcode.

This is causing the error ‘Add App Groups to your App ID’ inspite of adding the app-group to the correct app ID on enabling App Groups.

Please let me know if I could fix this somehow?

just in case, cause I’m not sure where your actual problem is located, I’m going to give you 2 answer.

  1. on the App Store connect, you make your apple bundle identifier there, (com.name.gamename)
    and 2. in unity you’ll open up build settings, then click player settings in the lower left hand corner of that window, in your inspector you’ll see a bunch of tabs under settings for iOS. click on “other settings” scroll down to identification and put the EXACT same bundle identifier there as you did in the App Store connect.

I really like this step by step, helped me out on the provisioning profile section
https://www.nmy.de/en/5/news/17/233/submitting-unity-apps-to-the-ios-app-store/