[Unity 2019.03.14f] Unable to launch game from unity hub

Hello,

I’ve got a problem in order to launch my game by the Unity Hub.

When I go to the Unity Hub I cannot launch my games. The Unity launcher start and then shutdown immediatly and the Hub show off again.

I’ve read a lot of thing about this kind of problem and nothing I found worked for me.

I got no proxy, no antivirus, I have disabled Windows Defender and the firewall.

I tried to launch my game with Unity 2019.03.12 and 2019.03.13.

I can create a project but not edit one. If I try to launch from the Unity Hub it gave me the same error.

I checked my logs and this show off:


Editor.log

[LicensingClient] ERROR Failed to
connect to local IPC

[Licensing::Module] Failed to connect
to channel: LicenseClient-Leo

[Licensing::Module] Successfully
launched the LicensingClient

[Licensing::Module] Successfully
connected to LicensingClient on
channel: LicenseClient-Leo

[Licensing::Module] Successfully
launched and connected to
LicensingClient Entitlement-based
licensing initiated

[LicensingClient]
Licenses Updated successfully in
LicensingClient

LICENSE SYSTEM [2020519 21:57:41] Next
license update check is after
2020-05-20T18:40:39

Built from ‘2019.3/staging’ branch;

Version is ‘2019.3.12f1 (84b23722532d)
revision 8696375’; Using compiler
version ‘191627012’ OS: ‘Windows 10
(10.0.0) 64bit’ Language: ‘fr’
Physical Memory: 32731 MB

[Licensing::Module] License is not
active (com.unity.editor.ui).
HasEntitlements will fail. BatchMode:
0, IsHumanControllingUs: 1,
StartBugReporterOnCrash: 1, Is64bit:
1, IsPro: 0 No valid Unity Editor
license found. Please activate your
license.

[Package Manager]
Server::Start – Port 52829 was
selected

COMMAND LINE ARGUMENTS: C:\Program
Files\Unity\Hub\Editor\2019.3.12f1\Editor\Unity.exe
-projectpath C:/Users/Leo/Rogue Like
-useHub
-hubIPC
-cloudEnvironment production
-hubSessionId 2dcb5800-9a00-11ea-9139-cffdf43d01d7
-accessToken zOyiU5F0-pnfKPga6r77rOu-9qcUHLJ5badawrcJQA8008f
Exiting without the bug reporter.
Application will terminate with return
code 0


upm.log

[2020-05-19T19:57:42.195Z][INFO]
Starting Server
[2020-05-19T19:57:42.202Z][INFO]
Server started on port [52829]
[2020-05-19T19:57:42.233Z][INFO]
Health Request received
[2020-05-19T19:57:52.208Z][ERROR]
[Unity Package Manager (Upm)] Parent
process [3020] was terminated


I’m desperate with this problem. I tried everything: I someone could help me it could be very good!

Thanks a lot for everyone who want to help me.

Downloading the version 2.0.4 of UnityHub fixed the problem. I’m keeping this post open because the last version of hub have problem.

Hi, I have the same problem after updating the UnityHub and I don’t have the installer of an older UnityHub version so, do you have any new solution?
Thanks