Unity 2019.3.0f6 iOS project import is stuck.

We have a Project of 95GB size when trying to import this into MAC OS for iOS platform with Unity2019.0.3f6, the import is stuck forever. After checking the Editor log in the console it shows


Mono: successfully reloaded assembly

  • Completed reload, in 8.938 seconds
    Registering precompiled user dll’s …
    Registered in 5.136730 seconds.
    Platform modules already initialized, skipping
    Validating Project structure …
    2.133991 seconds.
    Shader import version has changed; will reimport all shaders…
    Upgrading shader files …
    3.408591 seconds

Force close and restart again, it’s always stuck at line upgrading shader files and no more logs get printed after this, and the window of Force Quit Applications shows Unity not responding.

  1. We tried importing in 3 system which is Mojave 10.14.6, and Catalina 10.15.1.
  2. We tried importing after unchecking the option in Unity Preferences>compress assets on import.
  3. We tried importing part by part, but not able to open the project with all updates.
  4. We tried deleting shaders but it’s still stuck.
  5. We tried opening through Terminal commands and Unity Hub.
  6. We tried deleting the Library and Project settings folder and let Unity creates it again.

At present we are using Unity2019.1.8f1, wanted to Upgrade to Unity2019.0.3f6. Please help me if there is any other workaround or some things I can give a try.

For me the solution was to place empty adb1.txt file next to Asset folder

Founded on this forum post

I’m running Unity 2019.3.15f1 on macOS Catalina 10.15.5

the same problem