Unity 2019.3.3f1 forces system shutdown (macOS Catalina) during normal usage (still in 2019.4.1 lts)

Just by using the unity Editor in a normal way it suddenly shuts down.
Steps to reproduce:

Opening a tab that was hidden before like the asset store → immediate shutdown

Opening the games tab (not if it´s side by side with the scene tab) → immediate shutdown

sometimes opening even other tabs like the animator made my system go down.
It´s not even a unity beta version so that shouldn´t happen actually.
Also, I´m not experiencing that issue with projects that were created during 2019.3.

Stuff that I´ve already tried:

  • Updating and reimporting obsolete
    packages (including URP (before

  • restarting unity

  • trying out different versions of
    unity 2019.3

  • reinstalling it

  • searching for related issues (wasn´t
    able to find such an extreme one so I
    guess it´s maybe related to Catalina)

  • already downgraded the project once a
    month ago, but now downgrading
    actually would be the last option.

  • removing Assets that were
    unnecessary, or updated them

The game itself runs without an error it seems to be related to the tabs (as it´s only happening if the tabs are hidden and I open them)
Apparently that makes unity hard to use.

I´d appreciate every kind of help and as I´m not able to give you any log file I hope that explanation is enough(unity doesn´t inform me about any log file as the computer immediately shuts down, but maybe I´m able to find one in the Unity folders). Hope that this bug gets fixed soon or a solution to fix it locally is found

I’ve been experiencing this issue as well. Switching between the Scene and Game tabs causes an immediate shutdown of the entire computer. Haven’t found a successful workaround.

I have been struggling with this issue for some time now. I have digged through whole internet…

I figured that it happens more often when i am on the animator tab and / or working with animator controller.

It is very much annoying, restarting the mac because of some error is a joke and productivity reaches bottom :stuck_out_tongue:

I hope someone is going to respond and help us with that…

I’m also experiencing the same issue when I use the Animator Controller Window. Unity on my Mac suddenly crash and the only thing I can do is reboot the Mac!
Today I got this issue for 3 times in few minutes!!!

I already reported this bug to the bug report.

I’ve also been experiencing this problem on 2019.3.11

I’m new in Unity and having similar issue since late last week, every time when I hit “play” button even in a simple 2D playground project with only background setup it force shut down my laptop, and also crashed when I click on Game tab. Got this more than 3 times within 10 minutes.
Have tried downgrade to previous version but it doesn’t fix the problem.

2019.3.13 too!!! Animator~

Same here, the crash is happening very frequently on my Mac ( OS Catalina ).
It seems to be related to the Animator and Animation window.
Uninstalling unity is not fixing anything, unfortunately :frowning:

Same here.
iMac (Retina 5K, 27-inch, 2019)
macOS Catalina 10.15.5 (19F96)
Unity 2019.3.15f1

It only happens when Im in the Animator. Also, sometimes just before the crash, developer tools popup with a password request, after running this command:

sudo /usr/sbin/DevToolsSecurity --enable

The popup is gone, but it still crashes

Hey guys, it happens to me as well. In my case it is related to the FormerlySerializedAs attribute in a custom property attribute. I’m posting a link to my stackoverflow question and the answer, maybe it will help you a bit.


Im sure that issue is connect with Catalina and 2019.3+. (I tried several version of 2019.3+ since Jan.2020.)
Because when I uninstalled 2019.3+ then reinstall 2019.2+, everything works fine.

Unity 2019.3.5, I am experiencing the same issue both in editor run time and not. Especially during working with mecanim.

Sam here, ++

I’m having the same issue.

Guys, this saved me. I have embedded graphics card on my MacBook, and I guess that’s the reason why OpenGL 4.1 crashes it. (notice OpenGL 4.1 written in the window header when you launch Unity). So I launch forcing metal.
Here is the solution

This happens on my 2019.4.1(lts) too. I found it common when adjusting tab sized and when using package manager.

After including some animations unity starts to shut down the computer.
it is really annoying.
Have no clue how to fix it and it sees unity does not also sadly.

Version 2020.
Hp windows laptop.