Unity 2019.4.14f1 to Occulus quest 2: build completed successfully but not running on headset,Unity 2019.4.14f1 to occulus quest 2: build complete successful but not running on headset

Hello,

I am a beginner to Unity and Occulus Quest 2 and have been following along the Occulus Quest - Unity developer documentation to try and run the demo VR scene from Unity to Occulus QUest 2 headset using the USB3.0 cable that comes with the device and can charge the headset. I have installed the Occulus integration package, and switched the platform, changed the player settings etc. according to the documentation and added my App ID number. And Unity says that the build completes successfully but when I go to put on the headset, it just stays on the default menu environment. I have tried several times now, following the documentation, trying out different youtube videos, but I keep getting the same result.

I am getting a note from the Occulus app that my graphics card isn’t compatible with Occulus Rift and I can’t discover the Occulus Quest 2 using the Occulus desktop app either.
But I have followed along with the Unreal Engine to Occulus Quest 2 documentation and have been able to load custom VR scenes from my laptop into the headset using the same cable just fine.

Is anyone else encountering this problem?

Any help would be much appreciated.
,Hello,

I am a beginner to Unity and Occulus quest 2 and have been following along the Unity and Occulus Quest development documentation to try and launch the demo scene to the headset.
I am getting no error messages from Unity, it is saying the build completed successfully but nothing is showing up on the Occulus Quest 2 headset. It just stays on the default home menu environment.

I am getting a note from the Occulus app that my graphics card hardware doesn’t support rift.
But when I use Unreal Engine and the default charging USB 3.0 cable, my scenes load fine into the headset and I can walk around and teleport, move doors etc.

Is anyone else experiencing this problem?

So looking at the console report more closely, it says:

  • DeploymentOperationFailedException: No activity in the manifest with action MAIN and category LAUNCHER. Try launching the application manually on the device.
    UnityEditor.Android.AndroidDeploymentTargetsExtension.StartApplication (UnityEditor.Android.AndroidBuildProperties buildProperties, UnityEditor.Android.AndroidDevice device, UnityEditor.ProgressTaskManager taskManager) (at <12a2b75af02641e99fa5d5b4bf0b41f7>:0)
    UnityEditor.Android.AndroidDeploymentTargetsExtension+<>c__DisplayClass12_1.b__4 () (at <12a2b75af02641e99fa5d5b4bf0b41f7>:0)
    UnityEditor.ProgressTaskManager.Run () (at <68af50843d0a45398c92799647332ec2>:0)
    UnityEditor.Android.AndroidDeploymentTargetsExtension.LaunchBuildOnTarget (UnityEditor.DeploymentTargets.IDeploymentTargetsMainThreadContext context, UnityEditor.BuildProperties buildProperties, UnityEditor.DeploymentTargets.DeploymentTargetId targetId, UnityEditor.ProgressHandler progressHandler) (at <12a2b75af02641e99fa5d5b4bf0b41f7>:0)
    UnityEditor.DeploymentTargets.DeploymentTargetManager.LaunchBuildOnTarget (UnityEditor.BuildProperties buildProperties, UnityEditor.DeploymentTargets.DeploymentTargetId targetId, UnityEditor.ProgressHandler progressHandler) (at <68af50843d0a45398c92799647332ec2>:0)
    UnityEditor.PostprocessBuildPlayer+<>c__DisplayClass18_1.b__1 () (at <68af50843d0a45398c92799647332ec2>:0)
    UnityEditor.BuildPlayerWindow:BuildPlayerAndRun()

  • UnityException: Could not find any valid targets to launch on for Android
    UnityEditor.PostprocessBuildPlayer.LaunchOnTargets (UnityEditor.BuildTargetGroup targetGroup, UnityEditor.BuildTarget buildTarget, UnityEditor.Build.Reporting.BuildReport buildReport, System.Collections.Generic.List`1[T] launchTargets) (at <68af50843d0a45398c92799647332ec2>:0)
    UnityEditor.Android.PostProcessAndroidPlayer.Launch (UnityEditor.BuildTarget target, System.String installPath, UnityEditor.Build.Reporting.BuildReport report) (at <12a2b75af02641e99fa5d5b4bf0b41f7>:0)
    UnityEditor.Android.AndroidBuildPostprocessor.LaunchPlayer (UnityEditor.Modules.BuildLaunchPlayerArgs args) (at <12a2b75af02641e99fa5d5b4bf0b41f7>:0)
    UnityEditor.PostprocessBuildPlayer.Launch (UnityEditor.BuildTargetGroup targetGroup, UnityEditor.BuildTarget buildTarget, System.String path, System.String productName, UnityEditor.BuildOptions options, UnityEditor.Build.Reporting.BuildReport buildReport) (at <68af50843d0a45398c92799647332ec2>:0)
    UnityEditor.BuildPlayerWindow:BuildPlayerAndRun()

  • UnityException: Could not find any valid targets to launch on for Android

@kimchisalad
You need to add the Unity XR plugin which is under window, package manager. Make sure to click “show preview packages”. Then you want to create a camera with a tracked pose driver. For you second question I think it might be that your computer isn’t Oculus Ready but I wouldn’t be the person to ask about that since I’m not having that problem.

I know this is old but did you ever fix this issue?

I HAVE THE SAME EXACT ISSUE.

My game runs fine on the Quest, but fails with the same errors when trying to deploy for the Quest 2.

Check the file /Assets/Plugins/Android/AndroidManifest.xml.
And the settings for Player->Android-> then Other Settings, and Publishing Settings, see screenshots.
I’m using Unity 2021.1.

My AndroidManifest.xml looks like this, runs on both Quest and Quest 2:

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android" android:installLocation="auto">
  <application android:label="@string/app_name" android:icon="@mipmap/app_icon" android:allowBackup="false">
    <activity android:theme="@android:style/Theme.Black.NoTitleBar.Fullscreen" android:configChanges="locale|fontScale|keyboard|keyboardHidden|mcc|mnc|navigation|orientation|screenLayout|screenSize|smallestScreenSize|touchscreen|uiMode" android:launchMode="singleTask" android:name="com.unity3d.player.UnityPlayerActivity" android:excludeFromRecents="true">
      <intent-filter>
        <action android:name="android.intent.action.MAIN" />
        <category android:name="android.intent.category.INFO" />
		<category android:name="android.intent.category.LAUNCHER" />
      </intent-filter>
      <meta-data android:name="com.oculus.vr.focusaware" android:value="true" />
    </activity>
    <meta-data android:name="unityplayer.SkipPermissionsDialog" android:value="false" />
    <meta-data android:name="com.samsung.android.vr.application.mode" android:value="vr_only" />
    <meta-data android:name="com.oculus.supportedDevices" android:value="quest|quest2" />
  </application>
  <uses-feature android:name="android.hardware.vr.headtracking" android:version="1" android:required="true" />
</manifest>