Unity 2D sprite Renderer + Material Sprite/Diffuse shader not working

When the player goes underground a sprite that covers the player’s screen is enabled. A light centered on the player should create a little area in the middle that mimics the player’s sight in darkness. For some reason a light; no matter what type; doesn’t seem to affect the sprite shader/diffuse. I’ve tried playing around with the layers, order in layers, z values but it all doesn’t seem to fix the issue at hand. I’ve also tried playing around with the lighting settings in Unity but that also doesn’t seem to change anything.

Do you have any idea what I’m missing?

Found the fix myself. I’m using Tiled and Tiled2Unity. The imported sprites had a special Tiled material; when replacing that with sprite / diffuse it actually works!