Unity 3.0 lightmapping. houses dont throw a shadow?

I imported my houses from sketchup and ticked their "generate lghtmap UV's" options.But its showing the shadows from the terrain, only. Without showing shadows for the house!

What am i doing wrong? Which settings might be wrong?


Make sure your house is marked as Static, and "Baked Shadows" is turned on for your light, in the Lightmapping tab.