Unity 3.4.1f5 Windows 7 64-bit Very Slow, Should be Faster

So I’m a new user, just hopped on board with version 3.4.0, and it’s been selectively very slow on my computer. I haven’t done much with the editor yet, just toying around and learning the program. The areas that I’ve discovered to be slow are when moving objects in general, even a simple cube (it’s like moving that cube slowly across sandpaper, it hangs and catches and moves very uncleanly and sluggishly), consequently the test project lags horribly. When hitting the “play” button, Unity will hang for several seconds - up to ten or fifteen - before starting, and in general it just doesn’t act like it should. I’ve used Unity on another Win7 64 bit machine with slower hardware and had it work perfectly; same version, same day in fact. For example, a few days ago I created two cubes and named one base, the other cube; when I moved cube, it moved base, and when I moved base, it moved base. (Unfortunately I didn’t save that project… in hindsight, I probably should have.) It also crashes frequently. Navigating empty space is fine, as well as navigating filled space, except when using the scroll wheel, which performs similar to the moving of the cube: sluggish, jumpy and uneven.

For reference, my machine:

  • Windows 7 64-bit
  • i5-2500k
  • GTX560 Ti
  • (is there anything else that would be useful to know?)

Based on the above, I know it shouldn’t be slow, unless there’s something important I happen to be missing. Is there some kind of confliction with this hardware, or possibly a driver? I updated my drivers only weeks ago, so I can’t imagine it would be them.

I tried checking the Affinity (taskmanager) to make sure it was running on all 4 cores, but I wasn’t allowed by the system, if that makes any difference.

I really have no idea what’s wrong with it. Any help would be appreciated.

P.S.: None of the other questions seem to have anything similar to this behavior.

try downloading the 32 bit

I tried a lot of things, but it ended up being a bad Windows installation, marred by either a virus or just internally broken. Whatever it was, I re-installed Windows 7 recently, and Unity has run flawlessly since then, all versions from this one to the most recent (as of 7/15/12).