Unity 3d objects resolution issue

First time working on 3d. I see the objects are not smooth. Any idea how to improve that?

I think you’re talking about Anti-Aliasing. You can enable by going to edit > project settings > Quality > Anti-Aliasing.