Unity 4.2 editor crashes on startup when importing image files

I’ve been running a project in Unity 4.2.0 (with Windows 8) and it ran just fine, aside from a message about an out of size atlas. However, when I upgraded to 4.2.1, the Unity editor crashes everytime I try opening a scene in the project. It always crashes as soon as it tried importing one of the png files. I can open a new project just fine, it’s just this project that’s screwed up. All of my teammates (including some with Windows 8) are able to open the project with 4.2.1 without any problems. Strange thing is, even after uninstalling and reinstalling version, 4.2.0, the project still crashes. I’ve also tried opening Unity using command line prompts. Does anybody know what might be wrong? I can provide other details if needed.

I found the .exe file for the Unity editor, right-clicked, selected “Run with graphics processor,” and clicked “Change default graphics processor…” In the window that popped up, I changed it from integrated graphics to the dedicated graphics card.