Unity 4.6 Button is not working.

Hi, this seems to be a continuation of an old question I had but it was never answered. The way I fixed it originally was by replacing the buttons in my scene and adding new ones but even this time it is not working. I have a NPC with a chatbox (button which you can click to make the text proceed) and another canvas as a Store with 6 buttons as children which when you press it calls some functions when it is clicked. But the problem is that this was working originally but I had switched scenes and now the Store’s buttons cannot be pressed. I believe the issue has something to do with Event Systems, but the oddest things are that the store works fine in the other scene and that the chatbox button can still be pressed.


I think this is relatable, but i noticed that you have to have Event System present to if your buttons are to work. Just wanted to mention it.

Fixed it! The Canvas’ are World Space and I did not have a camera selected so the buttons wouldn’t get pressed.

Yep i needed the event system also

@MazeTard please don’t post your comments as a new answer. Same goes for @casanueva and @paulmac, even though your comments are a few months old.

I have both the camera selected for my canvas, aswell as an Event System in the hierachy, still not working.