Unity 5.1.0f3 crashing at splash screen

Unity 5.1.0f3 64bit crashes at the splash
screen on Windows 7 Ultimate 64bit, with fault module libcef.dll
Unity 5.0.3f2 and 4.6 work perfectly well.

Tried solutions:

-Launching Unity as admin and/or in compatibility mode.

-Launching Unity while pressing the alt key and with -force-d3d11

-Updating all drivers and running DxDiag

-Checking Windows DEP settings

-Reinstalling & Repairing

-Reinstalling on a different partition and physical disk

-Uninstalling, deleting Unity registry files, restarting, reinstalling

-Uninstalling, Removing the Pace Anti-Piracy license files folder,
restarting, reinstalling

-Searching for a .ulf file and deleting it in the install disk (none were
found)

-Using a different installer file

-Running CHKDSK on all disks

Hardware:

Asus z67-k

Intel i7 4790k

Radeon r9 290x 4GB

16GB DDR3 RAM

376Gb minimum free HDD space on possible install disks

Thank you in advance.

Need SP1 for Win7

Was able to solve this problem yesterday. It’s not what I expected… do a FULL windows update, and install every minor patch that is available. I did this, along with updating my GFX drivers, and everything worked perfectly. (Note: I’m on Win 8.1)