Unity 5.1.3 Stretch in build


Once I have updated to Unity 5.1.3 this happens to my game:

It may not be as obvious but the game stretches. My mouse cursor is supposed to be on the “options.exe” but instead the “echo.exe” is selected.
It didn’t do that before.

Also I have an options menu where the player can change the resolution so when you change it it comes back to normal. This is how it looks after the change, as it should look:

I have Fullscreen as default in Player Settings and Screen Width and Height set to 1600x900 on startup. No I cannot change these settings, the game has to have 16:9 aspect ratio.
It should not matter as with Unity 5.0.1 it worked fine.

Any help is appreciated!

I haven’t downloaded 5.2 yet, going to wait to hear if it has any weird bugs before doing so.
But this is very basic and should not happen!
The way I tried to fix it was when my scene started, I just had a line of code that set the resolution to 1600x900 so that kinda brought it back to normal.
But this is not desirable so I will wait for a fix.

@paulgaze If this is the same issue then I’ll have to wait for more than a month? Huh…