Unity 5.2.2 installation gets stuck

When installing Unity 5.2.2f1 (64-bit) on a clean Windows 10 installation (no antivirus) the installer always gets stuck at “Installing playback engines…”

When I look at the installer log, these are the last 4 lines:

Create shortcut: C:\Users\Public\Desktop\Unity 5.2.2f1 (64-bit).lnk

Deployment Image Servicing and Management tool
Version: 10.0.10240.16384

Image Version: 10.0.10240.16384

Any ideas on what is going on? I’ve tried the unity installer, the direct installation exe (~1.6 gig). I have tried to let the installer run, but even after three hours, it does nothing.

I shut down the process with the name “Windows Host Module Installer” (or something along those lines), and that seemed to immediately fix the installation.

I’ve left mine running for a good 12-13 hours to no avail, I too would very much like to know how to get over this hurdle! Doesn’t bode well when you can’t even install the software without running into trouble!

I finally got it to work by shutting down all other tasks (except for the essential windows tasks). Never had this problem in Unity 4.

I had the same issue, but I couldn’t figure out which tasks I should turn off.
This is why the best way for me to do it was by starting the PC in safe mode with networking.
Hope this works for anyone having this issue.

Thanks,

  • Juan.

I experienced the same thing trying to install 5.3.0f4 (64-bit). In the Task Manager I noticed a “Windows Setup” process (sorry, I can’t remember the exact name) that was consuming ~30% CPU for no reason. After killing that process, the Unity install immediately resumed, and ultimately completed with no further issues.

I recently had this problem, in windows 10 with unity 5.3

My fix was to pull up windows task manager and just start killing processes like it was going out of style and eventually unity just took a leap forward and continued installing.

I restarted normally and closed the WIFI, then install the 64bit Editor , it works offline and also without any other application running in the background

i come across with the same problem , getting stuck with the installing interface, never move forward!
i cannot find Windows Module Installer in task manager but some names like WMI host provider!
very sad! any chinese user meet the same problem ?

yes, just shut some ‘windows Module Installer’ or something it will be fiexed.
this is a new one of the unity stupid problems.

I had this same issue with the latest version at the moment, Unity 5.4.2. Apparently, this is not a new thing that happens. Thanks for the responses, as ending the task “Windows Module Installer” fixed it right away for me.

Same problem, Unity plus 5.4.2f2 stuck during documentation installation. I stopped Windows Module Installer and it seems to work… it’s now downloading the standard assets. Hope it won’t get stuck twice at 4:00 AM with Visual Studio…

When installers die like this usually threatening system shutdown and canceling will bump them.

Just had this problem with 5.4.3f1 install on Windows 7. I noticed MsMpEng.exe was taking a bunch of CPU time, so I went and disabled real-time protection in Microsoft Security Essentials, and the installer immediately proceeded.

Seems like real time virus checker doesn’t play nicely with the way the documentation is being installed.

Shutting Down the Windows Defender resolved it for me!