Unity 5.3.0f4 32bit blank screen

Is anyone else having this issue? When I start it up, the splash screen works fine, but when the next screen pops up, where I would select my project, it’s just blank. My cursor changes to the text cursor when I hover over an area where there should be text, so parts of it are working, but I cannot select a project, so I can’t start unity.

  1. Goto C:\Users\username_here\AppData\Roaming\Unity\Packages

Create a folder called node_modules.

Inside this folder create 2 further folders.


  1. Now goto C:\Program Files\Unity\Editor\Data\Resources\Packages

Using your favorite extraction tool.

Open unityeditor-cloud-hub.0.X.XX and extract (dist) and package.json to (C:\Users\username_here\AppData\Roaming\Unity\Packages

and then.

open unity-editor-home.0.X.XX and extract the same (dist) and package.json to (C:\Users\username_here\AppData\Roaming\Unity\Packages

Fire up unity and it works a treat.

Found the solution in the Unity forum


user Lertmind’s response on Wednesday fixed this problem for me on Win7.

Hope this helps someone else fix the problem.

I found packages unityeditor-cloud-hub-0.0.1.tgz and unity-editor-home-0.0.7.tgz in C:\Program Files\Unity\Editor\Data\Resources\Packages. Create folders node_modules\unityeditor-cloud-hub and node_modules\unity-editor-home in C:\Users%user_name%\AppData\Roaming\Unity\Packages. Extract dist and package.json from unityeditor-cloud-hub-0.0.1.tgz into unityeditor-cloud-hub, dist and package.json from unity-editor-home-0.0.7.tgz into unity-editor-home. It’s work.:slight_smile: Thanks, Yash987654321!

Im having exactly the same issue, 32 bit win7, intel i3 3rd generation ultrabook with intel HD4000 graphics. Was working perfectly with previous version, tried updating GFX driver but didnt fixed it.

Same problem here with the 32 bit version.

Worked perfectly… Thanks a ton yash!!

Can someone rewrite this with better grammar ?
I don’t know what is going where.

I can’t understand anything, can someone make a video tutorial

Been trying to figure this out for days! Thank you so much!

Thanks - same issue on win7x64 with a fresh install of Unity3D v5.4.1p4 - the subdirectories were not the same for me, but I did a fresh install of v5.4.1f1, and it created the correct subdirs. for reference, the key subdir chain appears to be:

but underneath that needs to be a whole set of editor template files and subdirs, without which, the new project screen will never appear.

For whatever reason, in 5.4.1p4, those subdirs had been partially created under:
and copying those directly as-is was not sufficient to get the Unity new project welcome screen to actually appear.
The template files and subdirs did seem to be contained in the compressed file

For me it was quicker to just reinstall 5.4.1f1, then reupgrade to p4
rather than using a magic crystal ball to realise all this in hindsight and decompress the package.tgz contents into the dist subdir…
Good for future reference I suppose :slight_smile:

I had newly installed the 64bit version on Windows 10 and the empty gray box happened even when I tried reinstalling. Yash987654321’s method worked great. Thanks for passing it on.

Thank you!!! I was suffered with this problem for three days. You helped me fix it

Same thing happened with me for Unity 5.4.2f1 64bit on Windows 10.

+1 for anthukne - their fix worked for me as well.

If you use only UI like me, the problem is that your canvas(es) are not attached to the camera, so :

  1. Select your canvas (or all of them if you have many)

  2. In the inspector : Render mode → choose “Screen Space Camera”

  3. Drag and drop your camera (from the hierarchy) into the “Render Camera” box (in the inspector)

It’s something that should be automatically fixed, but no… Have fun