Unity 5.3 Android UI Glitch

UPDATE: NOT FIXED in Unity 5.3.1

My game was running smooth on my Samsung Galaxy S4. I installed Unity 5.3 then exported the game. The game now as some weird glitches that flash in the game UI elements, like replacing some images by anothers. It happens more often when the game is proccessing, like click a button. But it’s completly random. When it happens, the game becomes extremly slow. I have tried put the camera clear flags to solid color, change the 32 bits buffer and other settings but that still happens. Don’t know what to do.

The bug only happens on Android, it runs well in editor and web. Also tested on another phones and this happens in every android smartphone.

Here are some images of the glitches:


UPDATE: This is Fixed in 5.3.1

https://fogbugz.unity3d.com/default.asp?753357_c0posgv3ivvtfqs2

That’s the link to the Bug. Hopefully it will be accepted and added to the Issue Tracker and we can vote it up. But for now, if you have any info to add to this, per the case: To follow up on this case, send email to bugs@unity3d.com mentioning ‘Case 753357’ in the subject.

same here, device is also Samsung Galaxy S4

I’m also seeing this on the Droid Turbo with a 2D game. My game has become unplayable if I publish it using Unity 5.3. Another issue is some of my sprites disappear during animations.
Here’s a link to the game published on the Android store with Unity 5.3 https://play.google.com/store/apps/details?id=com.ATeshGames.EggplantPanic&hl=en

Same problem with Nvidia Shield Tablet on android

Similar problems occur on Galaxy S3 and Nvidia Shield TV.
I think this can be related (video included):
http://answers.unity3d.com/questions/1110660/strange-graphical-glitches-on-andriod-tablet.html

same thing happens here, any solutions?

have you tried turning multithreading off ?

Please someone send a bug report to Unity so they can fix that in the next update. Thanks!

I have a similar case, but in 3D

Same things happen to me with 2D game. Back to 5.2 until next version…

Just adding the Nexus 9 tablet running Android 6.0.1 to the party. I have the exact same problem with this device.

Unticking the Multi-Threaded Rendering box in Player Settings resolved the glitches for me (tested on 2 separate Android devices). Not 100% ideal only fix I could find.