Unity 5.3 MonoDevelop can not be opend

Hi community,

i have a problem with the new version unity 5.3.

I downloaded and installed the new version with the downloader. After installing all components and starting the editor i tryed to lunch monodevelop to change a script.

But mono develop isn’t opening by double clicking the script.

When i’m trying to lunch mono manually, im getting the error attached error.

Hi guys, thanks for your suggestions.

After reinstalling Unity 5.3 with all the componets it is now working. I think the problem was ghost monodevelop process that crashed the installation of the new version.

if somebofy else has the same problem you should check your task manager for any mono develop processes and kill them.

@KK3KP i had the same problem, i just downloaded and installed the latest version of monodevelop and linked it in the preferences in unity worked a charm. http://forum.unity3d.com/threads/monodevelop-unity-5-9-preview-release.350016/

Right! Before new and fresh install make sure you’ve killed all monodevelop processes.
Or new monodevelop won’t be installed and you will stay with old and not even working monodevelop.
It’s not okay, that the installer don’t kill them either.

Mine didn’t open at all either. I fixed it by manually installing gtk-sharp which can be found under Unity\Monodevelop\GTKSharp. : )

I’ve had a problem very similar to yours and what I did to fix this was I downloaded the needed GTK# file from the Installer in Program Files>Unity> MonoDevelop> GTKSharp.( If prompted, Delete old GTK file and Re-Install GTK.) Then enter Unity and go to Edit>Preferences>External Tools>External Script Editor and Make Sure it is set to “MonoDevelop (Built-In)”. Another thing that may help (I don’t know if it 100% works) is to Install the .NET from MonoDevelops Site. Also MAKE SURE UNITY IS FULLY INSTALLED! What my first problem was , it was that the Unity download would stop downloading because in task manager(CTRL+ALT+DEL>Task Manager) The “Windows Modules Installer” was running, so you have to end this task. And all of the files ( including the MonoDevelop file folder) will be there after the installation is done. Hope This Helped!

Edit, Preferences, External Tools, External Script Editor Change this To MonoDevelop(built-in)
and that is all