Unity 5.4: Visual Studio Emulator for Android blackscreen issue

Hi there, I am trying to use Visual Studio Emulator for Android but when I launch the game, I get a blackscreen and nothing else. I tried this on completely new project with no script whatsoever but still same. I can open one of my old apk that has been builded by older version of Unity(can’t recall which one) and it works perfectly but even an empty project gives blackscreen in Unity 5.4. Here are the things I’ve tried:

Player Settings:

  • Use 32-bit Display Buffer: Both on and off

  • Graphics API: OpenGLES2(OpenGLES3 or"Auto Graphics API" gives error on
    launch and does not launch the game
    at all)

  • Multithreaded Rendering: Both on and off

  • Device Filter: I know the emulator works on x86 architecture
    but I tried FAT(ARMv7 and x86) anyway
    but no luck again.

  • Device Profile: I tried on API Level 23 and API Level 19.

Note that I can launch my game without a problem with my LG G3 device.

This seems to be a Unity-sided problem. If you are encountering this problem too please upvote this question so we can reach devs, even notify them if it’s not a known issue.

It does not seem working. Please read what other people comment this video