Unity 5.5.2 built iOS project does not contain necessary icons for submitting to AppStore

Since upgrading to Unity 5.5.2f1, I have been unable to submit my app to the App Store. When submitting, I get two errors about missing icon files from the CFBundleIcons entry (size 29x29 and 40x40). This did not happen with Unity 5.5.1.

I tried on Unity 5.5.2p1 and the problem still persists.

I tried resetting the icons in the Unity project and specifically overriding the iOS icons but to no avail.

Only solution was to use an online service to generate all possible icon sizes from a template of 1024x1024 and overwrite the AppIconSet folder manually.

Anyone else experienced this? I googled anything I could imagine but did not see any reports on this yet.

Yep, same problem. As it turns out, this issue only happens for us if the Target Device is set to “iPhone only” in Build Settings. Change it to “iPhone + iPad” and those previously missing icons get generated.

Update: I just submitted an issue to Unity with a simple repro project.

Update 2: I guess I should search before submitting duplicate bug reports… Unity Issue Tracker - [iOS] Some icons are not generated in built Xcode project when Target Device is set to 'iPhone Only'

We got this issue as well. For us it did already occur with 5.5.1p3. Tried to manually override the icons in unity but that does not seem to help.