Unity 5.6.2f1 Crashes on loading a project [FIXED]


I’ve just installed Unity 5.6.2f1 on my brand new, Windows 10 64-bit system, to find that when I try to load a project, Unity crashes, even if the project is new/blank.

A few interesting things to note is that this bug occurs on both the 32-bit and 64-bit versions and on the 64-bit version of whatever version is currently included with Visual Studio 2017. Also, despite running the installer separately, and the one included in the regular Unity Download Assistant, the Unity Standard Assets have never been available to add from the “Add Assets” menu on the create a project screen.

NEW UPDATE: I suspect it’s an issue with UnityShaderCompiler.exe located in [InsallationLocation]\Editor\Data\Tools64\UnityShaderCompiler.exe since when I try to delete it, it asks for admin. When I accept that, it STILL says that it requires admin. (I had a similar issue with some other file in Steam the other day). Could this be an issue with my PC rather than Unity?

I’ve repeated this with multiple projects, both creating and opening projects and included the error logs and memory dumps here.

To summarise though, the Memory Dump seems to always give exception 0xC0000005 (The thread tried to read from or write to a virtual address for which it does not have the appropriate access.) and the logs say:

Unity.exe caused an Access Violation (0xc0000005)
in module Unity.exe at [0023:01a41c54 OR 0033:419d03d3].

As a note: neither LavasoftTCPService.dll nor LavasoftTCPService64.dll are on the system, nor is AdAware or anything by Lavasoft for that matter, and running as an Administrator does not help.

For a collection of Crash Logs and Memory Dumps, [96880-unity-crashes.zip|96880]

Delete Library files (backup just in case) and reopen project. Worked for me.

Nevermind, I fixed it. I was correct with my assumption. After totally uninstalling and deleting all the files I was left with just that one. This is how I fixed it:

  1. Uninstall Unity
  2. Restart PC in safe mode, navigate to Program Files (or wherever Unity was installed) and delete the Unity folder
  3. Restart PC Normally an install Unity as you normally would.
  4. Close Unity and Navigate to Where you installed Unity to\Editor\Data
  5. Right click on “Tools64” and choose properties.
  6. Go into the Security tab and click advanced.
  7. In the new window, where it says “owner” click change, and in the box at the bottom type your user account name (as found at C:\Users) then click “check names” and then OK.
  8. Below the list of User permissions, click “Add” and in the new windows, at the top, click “Select a principal” and type “Everyone” in the box. Click Check names and OK
  9. Finally, give them FULL CONTROL over the folder. Now click OK until all the windows are gone.
    NB) If you get an error closing the windows at the end of step 9, you may need to repeat this process in Safe Mode.

Hello @TheWolfYT , I have the same problem, the only difference is that I have Unity 5.6.3p1. I followed your instructions and unity still crashes. Are you sure that the problem is the UnityShaderCompiler? if I install unity in another computer and open the project there, will unity still crash? is there anything else I can do to fix this problem?