Unity (5.6.2f1) won't start OSX 10.12 Need Help

I’ve tried everything. Remove / Install / Install Beta. Upgraded OS. Nothing is working. Every time I start Unity it looks like the start up window is about to appear and then it’s just a gray box. All the menu items are also grayed out too. The app isn’t crashing its just hung.

I finally figured out what the issue was. If you use the console app and watch the Editor.log under ~/Library/Logs/Unity it was attempting to open the index.html file (which didn’t exist) that contained your most recent projects. (~/Library/Unity/Packages/node_modules/unity-editor-home/dist/Index.html)

I renamed the ~/Library/Unity/ to ~/Library/Unity-old/ fired up Unity and got it all working again.

This was a major pain in the neck and it cost me getting my project done on time. The Unity3d team should have really dropped an error check in that line of code.

Error loading file:///%2FUsers%2F*********%2FLibrary%2FUnity%2FPackages%2Fnode_modules%2Funity-editor-home%2Fdist/index.html#/project/recent

(Filename: /Users/builduser/buildslave/unity/build/Editor/Platform/Interface/NativeWebViewWindow.cpp Line: 51)

Thanks! Your solution worked first try!