Unity 5 error after importing APPLOVIN! (for android)

Hello!
I have searched for quite a while but I couldn’t find a solution. I found somebody with the same problem but nobody answered him/her.
I have a problem when I imported AppLovin. whenever I try to install my APK file on my phone. The error states “error parsing package”. Is there something I need to do that I missed in AppLovin’s docs?

please help!

Oh and I have a question, does using 2 ad networks interfere with each other? I plan to use admob for banners and AppLovin for videos. Doesn’t the android manifest umm…“corrupt” when doing so? is there a way to merge two manifests ? If so what should I do?

-Thank you in advance!

Hi @adhamBe, This issue is resolved now.

I was also facing the same issue when I was trying to integrate AppLovin in Unity 5.3.3 I have searched allot but haven’t find any answer for this question and after spending 2 hours to resolve it, I found the problem and have resolved it.

First of all I would like to share my understanding about using 2 ad networks in single game: You can integrate any number of ad network in your game and not single of network will interfere with other. Even if there are two or more AndroidManifest files, unity will take care of merging all in one and etc.

now How to resolve Issue with AppLovin Ad Network in Unity5: I have seen that when you import AppLovin Package they set the minSDKVersion = “22” and problem is I don’t have such good higher end device :wink:
So what I do is I set the minSDKVersion = “15” because I am using Facebook SDK also, so I have to set it to API Level 15

Here is how my AndroidManifest.xml code was look like before fixing it:-

<uses-permission android:name="android.permission.INTERNET" />

<!-- These permissions are strongly recommended and will result in higher performance -->
<uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE" android:maxSdkVersion = "22"/>
<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" android:maxSdkVersion = "22"/>
<uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />

<uses-feature android:glEsVersion="0x00020000" />

<uses-sdk
    android:minSdkVersion="23"
    android:targetSdkVersion="23" />

and here is the fixed code of AndroidManifest.xml:-

<uses-permission android:name="android.permission.INTERNET" />

<!-- These permissions are strongly recommended and will result in higher performance -->
<uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE" android:maxSdkVersion = "23"/>
<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" android:maxSdkVersion = "23"/>
<uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />

<uses-feature android:glEsVersion="0x00020000" />

<uses-sdk
    android:minSdkVersion="15"
    android:targetSdkVersion="23" />

hope this will help all of you who were and will face such problem, and also hoping that AppLovin will fix it soon.

Let me know if it works for you or not…