Unity 5 keeps freezing when I try to build my Android project.

I have been using Unity for a couple of weeks now and have encountered very few problems. I’ve been working on an Android app for a couple of days and recently, Unity has begun to freeze on me whenever i click build & run.

Here’s what happens:

  1. I Click Build & Run
  2. The loading bar comes up with compiling scripts and the other things.
  3. Eventually it gets to detecting current tools version and sits there for 10 seconds and then moves on to detecting current build tools version and just gets stuck. The loading bar and the rest of the animations play normally but it just doesn’t progress.
  4. I wait for like 30 mins and nothing happens.
  5. I click cancel and Unity freezes but it doesn’t go gray. (Unresponsive programs go gray when you click on them).
  6. I click the Start button and nothing comes up.
  7. I press ctr+alt+del and nothing comes up.
  8. I hold alt + f4 and still nothing
  9. I eventually end up turning my computer off via holding the power button.

This problem is really frustrating since it keeps on making me restart and I’ve tried everything:
Unplugging my phone when building, reinstalling SDK, reinstalling Unity, ending the Java process via task manager when it freezes and other things but it still refuses to work. Anyone have an idea?

Update: I’ve tried building a PC&Linux standalone and it successfully builds and runs the .exe. It must be a problem with the SDK but i don’t yet know what.

Did you ever figure out what was wrong with it?