Unity 5 WheelCollider Jitter/Vibration

Hi all, I followed this PDF guide to create a simple car in Unity 5:

My problem is, at slow speeds, there is a lot of jitter and vibrations coming from the car. I can post a video if it is necessary.

I have tried playing around with the weights, and the suspension settings, but I still get the same problem.

Has anybody seen any information about this?

I think I had this problem and it was solved setting the sub-step parameters: Unity - Scripting API: WheelCollider.ConfigureVehicleSubsteps

I can’t remember what values I used and I’m not really sure how they affect things exactly, just tested some values like (5, 12, 15) and all the jitter stopped, without changing the suspension of the wheel (the car should move without jitter without forcing a fixed suspension or time scale). Like it’s explained in the docs, you only need to set this once for a wheel collider and every wheel collider.

I fixed this by going to the main car rigidbody and using the drop down menu and setting “Interpolate” to “Interpolate” from “None”.

Solved the problem by going to Project Settings > Time and decrased the Fixed Timestep Value.

So, setting interpolate did not do it for me… MaxMotorTorque is how I got rid of the jitters… but still tweakin’… It’s like redeveloping one’s game all over again! Why do I need a life I am but a lowly coding lackey. All the fine tuned parameters I had arrived at to get the perfect vehicle are all SHITE now! Gotta find the new magic combination! amnotmadnow! but when I am done, if I have lost the responsiveness and control I had so painfully reached on 4.x, iwillbemadthen!

Non scientifically:
On my bike, I got rid of jittering when I replaced my capsule collider with a box collider.
It was shaking even when standing still.

Good News Guys,

I’ve found a way to remove this bug of jitter/vibration,

First : If you have set your wheel collider’s suspension distance to 0, then set it to “0.1” or the least you can set is “0.05”, but not less that.

Second : Go to the car’s RigidBody and set “Interpolate to None”.

And it should help you guys, mine was fixed by doing this.

Sorry for the necromancy but I had the same problem on Unity 2018.2.6f1 and solved it by adding a box collider to my game object. The box collider was added to the car mesh ( Car9 1).