Unity 5 won't run editor

Hello, yesterday I had trouble opening Unity 5.1.3f. When I tried to create a new project, the window closed and even if the unity editor still showed up as a background process in the task manager, it didn’t appear at all on the screen.
I installed the latest version of Unity (that is to say 5.3.4f1) and that didn’t fix it.
Whenever I try to load a project, the same thing happens as when I try to create a new project: The window closes but still takes CPU and Memory (according to the task manager) as a background process.
Does someone know what I should do?

edit: By the way, I have tried double-clicking a .unity file, just to open the editor and trying opening a project from there… It just freezes on the unity splash screen.

_I run windows 10 64-bit (even if that is not the problem since it used to run perfectly about a month or two ago - despite which I have still tried running it in compatibility mode) _
I believe I am using a lenovo flex (i don’t know the full name) with intel i3, 2.90GHz.

This happend to me a year ago what I did was I uninstalled unity (you don’t have t olose your project files with this if you back them up) and downloaded unity 4.SO what you need to do is uninstall unity download unity 4 and then from unity 4 update to unity 5.I had the samew problem I was losing my minde cause noboody knew what to do, so I figured it out myself.Hope it works and again you don’t need to lsoe you game files.(It worked for me do good luck)