Unity Accelerator connection failed

Hello everyone.

Looks like I can’t connect to the Unity Accelerator and I don’t know why.

I’ve done these steps:

  • Installed Unity 2019.3.0f6

  • Installed the Unity Accelerator for Windows (Win10 64bits) from Unity - Manual: Unity Accelerator

  • Got the IP and Port at the end of the installation (ex: localhost : port)

  • Opened Unity with empty project

  • Edit → Preferences → Cache Server (global)5454561--556866--upload_2020-2-7_12-24-51.png

  • Tried localhost and 127.0.0.1 and both shows “Connection failed”

  • Checked the service if it was running. It was:

  • Disabled all firewall

What I noticed is that when I open Unity it pops 02 errors:

- Socket: bind failed, error: An attempt was made to access a socket in a way that is prohibited by access permissions. (10013)
- Unable to join player connection multicast group.

Anyone faced the same problem and found a solution?

Best,

@ChenySchmeling , in your picture of the settings, it appears you have not included the port number that the Accelerator is listening on (default choice is 10080): 5454912--556908--upload_2020-2-7_8-54-8.png

This might be the problem. For example, if you are running the Accelerator on the same host as your Editor is running, you’d use something like localhost:10080 in that box.

Additionally, there’s no real benefit of using the Accelerator for a local Unity Editor outside of testing the functionality. The new Asset Import Pipeline now caches internally to achieve the same results (e.g. to make it painless to switch builds between platforms).

@bradunity Thanks for the reply!

I've went to another machine and opened Unity (same version) and tried as you said:
5454987--556911--upload_2020-2-7_14-14-31.png

The pcs are in the same network and I can access the Accelerator machine remotely, share files, ping etc but the connection still fails.

Any thoughts?

Hmm, not sure. Another test you can try is to access the Accelerator’s health endpoint. It’s usually hosted on port 80, so often you can try something like http://192.168.0.69/api/agent-health (the actual port value is listed as the value of LastUsedHTTPPort found in the unity-accelerator.cfg file in the storage directory you chose, in case it couldn’t listen on 80). You should also be able to access it from a browser running on the same machine using localhost.

Might be worth a peek into the unity-accelerator.log file or the editor log file for more clues. Additionally, you can enable extra logging by editing the unity-accelerator.cfg and changing the Debug value to true and restarting the service.

The health check also does not work, looks like the server did not compile correctly.

By changing the Debug to true and checking the logs I could see some “SyntaxError” and “failed to execute”. Should I post them here or send a PM?

Sounds like whatever change you made to the file may not have been saved in a format the Accelerator can read. Possibly might be line endings since you're on windows, or perhaps you didn't follow the value with a comma? The app itself doesn't compile anything, it's a standard executable.

Hello. When installing, uncheck the Asset pipeline v1 and it will work.

I can see the unity-accelerator is listening 80 and 10080, and I can open 80 port in browser. But the check connection always fail on 10080 port.

When I enter 80 port in the Default IP Address box, check connection is successful. But I think the right port should be 10080.

Same problem here, from newest version of Unity (2019.4.7f1) it hangs out on :80, and on :10080 reports that “Connection failed” even though the accelerator instance is up and running. It was working previously when it first connects to :80 then I manually change :80 to :10080 and never click Check Connection again.

Thank you for the report – I’m guessing you meant to type 2019.4.7f1? The accelerator is only supported from 2019.3 onward.

Yes! Sorry for that. If there is anything that I can provide, please let me now!