Unity Accelerator not transferring data on Ubuntu 18.04: cannot open bbolt database

Hello,

I am setting up Unity Accelerator on Ubuntu 18.04.
The service is starting, and the dashboard can be accessed, however, no data transfer can be made, and the logs show an error over and over again:

{"level":"error","ts":"2021-05-21T07:41:57Z","msg":"tool wrun exited","error":"wrun execute returned errors: [cannot open bbolt database: timeout]","errs":"[cannot open bbolt database: timeout]"}

Since I could not find any documentation on this, I've tried installing the go bbolt database and and it to the PATH variable, and restart unity accelerator, but it did not solve the issue.

Can you please help?

Thank you!
Sorin Janosi

Usually this happens because the accelerator is trying to run more than once; the "timeout" part is that bbolt uses file locking and obtaining the file lock is timing out. It could also be a permissions issue; you can double check those for the path <acceldir>/cachedb/bbolt.db -- I usually just run file <path> as the user the service runs as to double check.

Bbolt itself is an internal-to-an-app database, meaning it's a simplifying database that needs no distinct server, it can be compiled right into the accelerator itself.

If you have nothing cached yet, or don't care about losing what is cached since it's not running properly anyway, you can try the following:

  • Shutdown all instances of unity-accelerator running. First systemctl stop unity-accelerator and then ps aux | grep unity-accelerator and kill away.
  • Remove the entire <acceldir>/cachedb and <acceldir>/cachedbpending directories.
  • Start the service back up with systemctl restart unity-accelerator

Hopefully that clears things up. If not, I would next recommend uninstalling and reinstalling.

Thank you Gregory! this solved my issue. I appreciate the help!

I ran into the same issue on Window. How do I fix this on Window?

2023/05/11 09:19:58 bolt.Close(): funlock error: The segment is already unlocked.
2023/05/11 09:19:59 bolt.Close(): funlock error: The segment is already unlocked.
Wrun exited with error: wrun execute returned errors: [cannot open bbolt database: timeout]