Unity ad is not supported when build for android?

CODE:

using UnityEngine;
using UnityEngine.Advertisements;
using UnityEngine.UI;
public class AdManager : MonoBehaviour {

	public string adId = ".........";
	public Text txt;
	
	void Start () {
		DontDestroyOnLoad (this.gameObject);
		if (!Advertisement.isSupported) {
			txt.text = "not supported";
			return;
		}
		if (!Advertisement.isInitialized) {
			Advertisement.Initialize (adId, false);

		} else {
			return;
		}
		StartCoroutine (isAdReady ());
	}

	IEnumerator isAdReady(){
		while (!Advertisement.IsReady ()) {
			txt.text = "not ready";
			yield return null;
		}
		txt.text = "ready";
	
	}

In editor it shows that the ad is ready to display, But when I build for android it says the ads are not supported. And also there is an error when I run the game as (line 16):

MissingMethodException: Method not found: ‘UnityEngine.Texture2D.LoadImage’.

Which is on the line where I initialize the ad. This maybe reason for not supporting the ads.
Somebody please explain how to solve the issue?

picture of the error inside editor:
![1]

picture of the script look the line 22 where editor shows the error

Unity version: 2017.2.0f3

According to the log, when you initialize the Advertisements Advertisements.Advertisement.Initialize() gets called, which in turn, calls Advertisements.Editor.Placeholder.Awake(), and then, inside that Awake(), a call is made to Texture2D.LoadImage(), which is invalid for Unity version 2017.2.0f3.

You must update the Unity Ads plugin. If you are using the internal (integrated) version of Unity Ads, just open the “Services” Window in Unity, and click on “Ads”. If you are using the Asset Store version of Unity Ads, then import the latest version from the Asset Store.

Hi, out of your question, but only to you know.

the correct is achievements not acivements

:slight_smile:

From Unity 2017.0.x MissingMethodException: Method not found: ‘UnityEngine.Texture2D.LoadImage’ is not supporting plz delete unity folder and update from link:
Unity Monetization Legacy (Please get from Package Manager) | Services | Unity Asset Store

This solved for my project.