Unity Ads not ready.

I finished an app, and checked that it was working, including Ads. It worked both on the phone, and in editor.
After I was done with signing the app to publish it in google play, ads stopped working.

I made sure Advertisement.isInitialized is true, yet Advertisement.IsReady() is NEVER true.
I tried waiting, I tried making a coroutine and showing the app as soon as its ready, but it never is.
Works good in editor.
What happened? Im at the end of my rope here, why did it suddenly broke? I tried building debug(unsigned) again, but it did not help.
Tried showing all the ads from the Dashboard, and just calling default one.
Nothing works, please help, going crazy here!

Is there anything you are doing before you call Advertisement.IsReady() ? And are you also showing the Advert after that statement?

If you have not seen this youtube video already you should watch it, it might solve your issue.

Also, make sure you connected to some sort of Internet Connection.

The answer was to disable Ads, uninstall plugin, set build to PC, and then install and set it all again, exactly as it was before.
I dont know what happened and why, but hard reset apparently solves it.