Unity Ads - Skip and Close Buttons Do Not Respond to Clicks

So I’ve implemented Unity Ads in a project before with no problem.

I was working on putting together a How To and was streaming the implementation for another project when I hit a road block.

For whatever reason, the same implementation is not working in this second project. The Unity test ad displays just fine, BUT I cannot close or skip the ad. The game is essentially stuck on this ad screen.

You can watch me ride the struggle bus:Twitch

Just skip towards the last 1/4 of the video to see where the Unity ad does not close. Any suggestions on what’s not working?

Hey @howard-joshua-r , can you post your code? Both for AdManager and any code that calls methods in that class.

@kyle-unity thanks for taking a look!

AdManager is attached and here is the example calling code:

if (isGameOver)
{
AdManager.adManager.StartFullScreenAd();
if (!AdManager.adManager.GetIsAdRunning())
{
isGameOver = false;
//need a better solution for pausing gameplay while the ad runs
RestartGame();
}
}

6765382–781513–AdManager.cs (3.1 KB)

Thanks! Hmm, I don’t see anything obvious here that could be causing this. One thing I’ve seen in the past is code that repeatedly tries to show an ad every frame, which ends up looking like the editor preview window never closes.

It doesn’t look like that is happening here, but just to be sure, try putting a Debug.Log call next to where you call Advertisement.Show()

Have you tried building to a device? The editor functionality is just a placeholder so knowing if the functionality is broken in a live build would help give us more insight here.

@kyle-unity thanks again for taking a look!

I saw others have had the same issue where the Ad plays on repeat, but yea I think this version handles that.

I do have a couple of debug logs that show the Ad is ready and then again that the Ad is displayed. Just don’t get any response from the GUI. Couple of things to note:

  1. This same implementation works in another project.
  2. The first time around I noticed that there was no ‘skip’ button. After adding in the correct GameId’s for the Android Ad Service, the ‘skip’ button was then being displayed. (wondering if something got the Ad service into a state like this?)

I’ll let you know when we take a shot at the mobile deployment. Thanks again! Appreciate the help!

I also had this problem.:face_with_spiral_eyes: I had created an empty scene ‘ads’ and when that was loaded it run a script to call my adsManager.adsManagerInstance.showAd(); The ad was shown but I couldn’t interact with the buttons. The solution was just to add an Event System object to the ads scene: Game Object → UI → Event System

That’s it, now it’s working! :slight_smile:

4 Likes

That seems to have fixed it for me as well. I’m using editor version 2020.3.41f1
This was editor only.

This worked for me too.
Using editor version 2020.3.19f1
By the way If it’s editor only, I’m curious whether it would work fine if i delete Event System

By click on close button of game, app getting crash.