Unity ads unit page keeps redirecting me to the about page.

Hello, I’ve been trying to set up ads on my Unity game and have come to a block that is preventing me from finishing. I click on the ads units tab in the monetization section of the dashboard and it simply just takes me right back to the monetization about the screen. It keeps saying to get started with monetization and I have selected my option over 5 times now and it keeps none of it and just redirects me when I try to go to ad units.

This other person here had the same problem and was able to resolve it but never shared how: https://forum.unity.com/threads/unity-ads-ad-units-problem.1337348/

Here is an example of my issue:

Edit: Anything above the Organization Heading and under the Project Overview redirects me.

Ad Units, Unity Ads Reporting, Ad Controls, Testing, and Settings.

I am also having this issue. I’ve tried reinstalling all ad related packages in the Unity Editor, and while looking at the Mediation Window, it is showing Unity Ads Adapter as installed and configured.

Solved! For anyone in the future who may experience this issue, I switched browsers and it worked. This may not work for you but it certainly did for me.