Unity Android game freezes on splash screen

Few days ago my simple android game could successfully build and run on my tablet. On the first scene I loaded Google Play Services and authenticated the user. Everything worked correctly.
When I started to work on achievements, 5 test achievements I implemented correctly. But when I was changing them on actual achievements for my game something gone wrong and now my game freezes on Unity Personal edition splash screen and nothing happen.

Does anyone have an idea what I have unintendedly done?

I have totally the same problem. I’ve been developing the application for almost two years all builds worked well. After publishing to Google Play and added new patch version with expansion application freezes on Unity Personal Edition screen. But seems like only for devices on what older versions of my game were installed. Should work good on new devices. Uninstallation, deleting main folder and device rebooting are not helping.

Have you fiddled with the build settings and checked something you hadn’t before?

Is there any update on this problem ?