Unity Animation Import very slow


I have the problem that importing my character with animations takes a very long time, roughly 10 minutes which is incredibly annoying when I just want to change something small in an animation or even just apply on the object in Unity. I use the Rifigy addon in Blender to animate the character and then import the .blend file to unity. The character is quite low poly, around 15k tris, so that shouldnt be a problem. However, there are roughly 75 animations ranging from roughly 40-80 frames each. The import time has increased with each new animation.

I have tried to export is as a fbx instead of using the blend file itself and it is still pretty much just as slow. Is there anything I can do to decrease the time? It feels unreasonable it should take this long…

Thanks in advance!


Indeed, 10mn looks like pretty annoying.
Just some ideas:

Have you tried to export a simple animation (50-100 frames) and then import it into unity to see if it is slow too ?

It may be because you are working from a local network and not directly from your hard drive ?

Did you checked that the animations aren’t baked ? (=there’s an animation key on every frame on every bones) I don’t know much Blender but i guess there’s a checkbox to bake animations like there is in 3ds max.

EDIT: it may be caused by the modifications you directly made in unity. For example, when you check the box ‘generate lightmap UV’ on an heavy fbx in unity, it will take time when you Apply the modification or when you re import the fbx.

So maybe the fact that you have 75-80 animations in the same timeline, unity has to split all the animations every time and it may take some time ? (i don’t know if that kind of operations take time actually, but again, just an idea)

If this is the cause, then i advice you to split your animations in different fbx. May be one file for every animation, or for a group of animations of the same type, …

Thanks for the answer, unfortunately the problem persists.

When we started the project and had only a few animations, the import was much faster. The import time has increased with each animation.

I am working from a local drive, so it’s not that.

I cannot bake the animations as i import the .blend file itself. Well i could, but that would be more painful than waiting for the import.

Once it is imported the animation preview window and the whole inspector is super sluggish as well when the model is selected from the project window.

I tried unchecking lightmap uv’s, weld vertices and import blendshapes, did not help.

In blender, the animations are split into different actions(takes) but maybe unity sees it as a single timeline and has to split them anyways? I can’t really export the animations seperately without having several workfiles since i import the whole .blend file. We use a Unity plugin that converts the rig from blender to one that is compatible with mechanim, and that requires the file to be a .blend file. I did export the character as an fbx just to see if it could be the plugin that slowed things down, but i got the same result.
I have a bunch of import warnings on the mesh. Stuff like: “Bone is inbetween humanoid transforms and has rotation animation that will be discarded” and “Clip ‘name’ has import animation warnings that might lower retargeting quality”. Maybe it has something to do with this?

any update on this? i also am experiencing very slow import times, a few minutes at least, every time i import or apply a change to my character. i should mention my character is from daz to blender then blender fbx to unity. but i did not have this issue directly from daz to unity (but thats worthless), so who knows whats going on.

Hello person searching Google for an answer to this (5 years later).

Bake Animation being enabled in the Blender 3.0 FBX export dialog is definitely the culprit for me on this issue (it occurs even if the scene doesn’t even have any animation to bake in it). Anyways, with it enabled my import for an non-animated environment sky rockets from 5 seconds to 30+ minutes.

I’m not sure what the solution is though for a scene where you do have animation you intend to import, other than try and reduce the frame range as much as possible? But experimenting with the Bake Animation settings is where I would personally start.