Unity assets not importing from folder; scripts can't be created

I’ve suddenly stumbled upon a very strange bug with Unity 5.5.4p4 on Mac OS High Sierra. I created a new project, using Unity for the first time in probably a month or so, and found that no assets were able to be added to the project.

If I create a file in the Assets folder, Unity will not add it. If I create a folder through the Unity window and then drag a file from Finder into the Window, the asset panel will suddenly “forget” the folder I created. The folder continues to exist and is visible in Finder, but the asset panel will not show it or any other files. When I try to create a script, no component is added to the GameObject and no file appears in the asset browser. When I try to create the script again, it says a script already exists with the name; viewing the folder in Finder confirms that the file has indeed been created.

I’ve tried uninstalling Unity and deleting all preferences multiple times and creating a totally different folder for my project. Nothing has fixed it, and I’m out of troubleshooting ideas. Google hasn’t turned up anything either, so I’m inclined to believe this is a very uncommon issue.

I’m having the same problem with the same version (5.5.4p4) in macOS High Sierra.
I happened to update both Unity and macOS at the same time, so I couldn’t tell which caused the problem.