Unity broken, hangs at "Loading..." screen. Help!

Getting the stats out of the way first - Intel Core i5-8250U CPU @ 1.60GHz, Intel UHD Graphics 620, Windows 10, 8Gb RAM.

So I was using Unity 2018.2.2f1 and it was working fine. I started it today for the first time in about a month (I’ve been busy) to start a new project. I created a new 3D project, and from the Services box I added InApp Purchases to the project. Being only an Android developer (I have no iOS or other devices to test on) I unticked the iOS options and clicked Import while leaving the rest ticked. Unity popped up a message that said a new version was available, and I should upgrade to 2018.2.6f1, so I did.

When I finished its installation, I ran Unity 2018.2.6f1, but it got to the “Loading…” screen after clicking the Unity icon. A blue line slides to the left, then all the way to the right. And that’s as far as I get.

I’ve tried uninstalling Unity, deleting all files that the uninstall missed, deleting all previous project files, reinstalling 2018.2.2f1, no go. Uninstalled again, went through the Windows registry and removed all references to Unity, reinstalled 2018.2.6f1, still nothing. I was wondering if it’s just running particularly slow for some reason, but it’s been sitting at the Loading… screen for the last hour.

Oh, and between each uninstall → reinstall, Windows was shut down and restarted.

Any help on how to resolve this would be greatly appreciated. I’m completely stuck on this and need Unity to work again!

I had a similar issue today even before upgrading. It turns out in my case, the issue was that I had a VPN enabled which must have affected Unity being able to validate its licence (eventhough I use the Personal version), so after disabling my VPN, it worked fine.

Aside from this I have heard other people have had this issue because Unity doesn’t like a perticular USB device; I have read for some people it has been their mouse or keyboard and others it has been game controllers, so maybe try running Unity with only the essensials connected?