Unity bug - can't test game

When I clock on the play button to test the game, it just freezes and I can’t do anything, I tried reopening Unity, restarting Computer and even reinstalling Unity, but nothing seams to work. It worked fine for the first 2 weeks with no problems, but suddenly it started doing this. Any help?

Like Eric5h5 wrote in his comment, you probably have a script issue.

I would look through all of your scripts (hopefully you don’t have many). First look at the actual loops. Then look at any code that might have recursive calls (functions calling themselves, directly or indirectly).

If you know what you were working on when the issue first appeared, look there first.

If you don’t think that it was a script issue, try removing all scripts from your objects to be sure (and remove any editor scripts you might have as well). If you don’t want to remove scripts from objects, make a copy of the project and remove them there.

If this helps, i had the same problem before. After a bit of tests, i realised the “==” and “!=” operators i’ve overriden were recursively calling themselves…
If you’ve added some recently try checking them first. In any case, since it’s begun freezing recently it must be something you added of changed recently.